avoid_web_libraries_in_flutter

Group: errors

Maturity: stable

Linter v0.1.101

Since info is static, may be stale
flutter

View all Lint Rules

Using the Linter

Avoid using web libraries, dart:html, dart:js and dart:js_util in Flutter packages that are not web plugins. These libraries are not supported outside a web context; functionality that depends on them will fail at runtime in Flutter mobile, and their use is generally discouraged in Flutter web.

Web library access is allowed in:

otherwise, imports of dart:html, dart:js and dart:js_util are disallowed.